🔄 Losowy artykuł
Szlaki górskie Pociągiem dookoła Polski Podróże kulinarne Hotele-unikaty świata Parkingi przy lotniskach Łowiska Europy Campingi dla kamperów Imprezy — atrakcje w Polsce Poradnik pilota drona Wydarzenia i bilety Promocje bankowe Kamery na żywo Oferty Centrum Podróży Koliber Triper.pl Trip.FazaFM.com — plany podróży

Gopher

Gopher – protokół klient-serwer, pozwalający na rozpowszechnianie informacji w powszechnych lub kampusowych systemach informacyjnych (ang. world/campus-wide information system, CWIS). Powstał w kwietniu 1991 roku na University of Minnesota Microcomputer, Workstation, Networks Center w celu dystrybucji informacji wewnątrzwydziałowej.

Był pierwszym rozpowszechnionym systemem informacyjnym w sieci integrującym różne protokoły: FTP, telnet, WAIS własne struktury danych z możliwością dostępu do różnych typów danych, tak czysto tekstowych, jak i grafik i danych czysto binarnych (archiwów wszelkiego rodzaju). Został później wyparty przez WWW z powodu sztywnej, hierarchicznej struktury (gdzie jednym z elementów ścieżki dostępu był typ pliku), niewygodnych metod tworzenia serwisów, braku pełnej „multimedialności” oraz dlatego, że WWW zyskał większe wsparcie tak producentów jak i środowisk akademickich.

Pierwszy serwer gophera w Polsce został uruchomiony w końcu listopada 1992 roku, był to gopher.torun.edu.pl, jego administratorem był Rafał Maszkowski.

Standardy

  • Gopher Reference Material Repository (link gopher; en)
  • F. Anklesaria i inni, The Internet Gopher Protocol (a distributed document search and retrieval protocol), RFC 1436, IETF, marzec 1993, DOI: 10.17487/RFC1436, ISSN 2070-1721, OCLC 943595667 (ang.).
  • EARN Staff, Guide to Network Resource Tools, FYI 23, RFC 1580, IETF, marzec 1994, DOI: 10.17487/RFC1580, ISSN 2070-1721, OCLC 943595667 (ang.).
  • J. Foster, A Status Report on Networked Information Retrieval: Tools and Groups, FYI 25, RFC 1689, IETF, sierpień 1994, DOI: 10.17487/RFC1689, ISSN 2070-1721, OCLC 943595667 (ang.).
  • T. Berners-Lee, L. Masinter, M. McCahill, Uniform Resource Locators (URL), RFC 1738, IETF, grudzień 1994, DOI: 10.17487/RFC1738, ISSN 2070-1721, OCLC 943595667 (ang.).
  • R. Fielding, Relative Uniform Resource Locators, RFC 1808, IETF, czerwiec 1995, DOI: 10.17487/RFC1808, ISSN 2070-1721, OCLC 943595667 (ang.).
  • T. Berners-Lee, R. Fielding, L. Masinter, Uniform Resource Identifiers (URI): Generic Syntax, RFC 2396, IETF, sierpień 1998, DOI: 10.17487/RFC2396, ISSN 2070-1721, OCLC 943595667 (ang.).
  • P. Hoffman, The gopher URI Scheme, RFC 4266, IETF, listopad 2005, DOI: 10.17487/RFC4266, ISSN 2070-1721, OCLC 943595667 (ang.).

Linki zewnętrzne

ℹ Źródło: artykuł „Gopher” w polskiej Wikipedii. Treść dostępna na licencji CC BY-SA 4.0; lista autorów w historii edycji. Wersja może się różnić od aktualnej na Wikipedii (kopia odświeżana okresowo).
💳 Revolut
Karta wielowalutowa do podróży — płacisz za granicą bez przewalutowań.
Odbierz kartę →
💰 ZEN.COM
Konta multiwalutowe i karty — płatności bez granic z poziomu aplikacji.
Sprawdź ZEN →
🌍 Wise
Przelewy za granicę po realnym kursie — bez ukrytych marż.
Wypróbuj Wise →
Linki polecające — obowiązują regulaminy usług.
FazaFM.com — radio i newsy Hrubek.pl — Hrubieszów blisko Ciebie Gorzkie Groszki — blog